Quizz start error in LMS 4.X

When I start quiz I see the error:


Server Error in '/' Application.

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
Microsoft.SharePoint.WebPartPages.ListFormWebPart.EnsureList() +544
Microsoft.SharePoint.WebPartPages.ListFormWebPart.EnsureListAndForm() +34
Microsoft.SharePoint.WebPartPages.ListFormWebPart.UseLegacyForm() +135
Microsoft.SharePoint.WebPartPages.ListFormWebPart.CreateChildControls() +126
System.Web.UI.Control.EnsureChildControls() +188
Microsoft.SharePoint.WebPartPages.WebPart.get_WebPartMenu() +25
Microsoft.SharePoint.WebPartPages.ListFormWebPart.CreateWebPartMenu() +46
Microsoft.SharePoint.WebPartPages.ListFormWebPart.OnLoad(EventArgs e) +50
System.Web.UI.Control.LoadRecursive() +94
System.Web.UI.Control.LoadRecursive() +189
System.Web.UI.Control.LoadRecursive() +189
System.Web.UI.Control.LoadRecursive() +189
System.Web.UI.Control.LoadRecursive() +189
System.Web.UI.Control.LoadRecursive() +189
System.Web.UI.Control.LoadRecursive() +189
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2935

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18045


 

Issue with quizzes is caused by the SharePoint issue which is already fixed by the latest Cumulative Updates. 

Issue happens in SharePoint 15.0.4420.1017 - RTM. 

There is no issue since SharePoint 15.0.4517.1005 - June 2013 CU. 

Therefore, please consider to install at least June 2013 CU.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Please sign in to leave a comment.